Skip to main content

How can we help?

Why is the newest model AS90TA only BT version 4.2, but older model AS90T and AS90P is 5.0?

Comments

0 comments

Please sign in to leave a comment.